Android Studio Layout设计器加载错误

Mac下升级Android Studio至最新版本后,修改Activity的layout文件时,发现设计器报错无法使用

1、当加载layout文件时,编辑器提示错误“Android Nougat requires the IDE to be running with Java 1.8 or later”,如下图:

123

2、直接检查工程“Project Structure”后,发现JDK已经为1.8版本,应该与此无关

qq20160914-12x

3、查看Android Studio信息如下图,发现Android Studio IDE运行在Java 1.6版本下:

%e5%b1%8f%e5%b9%95%e5%bf%ab%e7%85%a7-2016-09-14-%e4%b8%8b%e5%8d%8812-56-39

解决步骤:

1、先确定系统是否已经安装JDK1.8,如未安装可以去Oracle站点下载最新JDK

2、安装完JDK后,打开以下文件:

/Applications/Android\ Studio.app/Contents/Info.plist

3、修改“JVMOptions”项目下的“JVMVersion”字段,作者修改前此处值为“1.6,1.7+”,修改为“1.8”保存退出

qq20160914-02x

修改为

qq20160914-22x

4、启动Android Studio,再打开设计器发现可以正常使用了